Hintergrundbild wird nicht angezeigt

Dieses Thema im Forum "Clientseitige Programmierung (HTML, JavaScript)" wurde erstellt von Dahli, 6. Februar 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Dahli

    Dahli Inaktiv

    Hallo, Leute!

    ich erstelle eine Website mit Dreamweaver. Wenn ich ein Hintergrundbild in eine Zelle einfüge (als Hintergrund), dann wird die Grafik zwar im DW-Vorschau-Fenster angezeiogt, wenn ich dann jedoch IE öffne, wird der Hintergrund nicht angezeigt!
    Dies ist der Code:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
    "http://www.w3.org/TR/html4/loose.dtd">
    <html>
    <head>
    <title>Unbenanntes Dokument</title>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    <style type="text/css">
    <!--
    body {
    background-color: #000000;
    }
    -->
    </style></head>

    <body>
    <table width="100%" height="393" border="0">
    <tr background="gfx/header.jpg"><td height="150" colspan="3">&nbsp;</td>
    </tr>
    <tr>
    <td width="143" height="294">&nbsp;</td>
    <td width="700">&nbsp;</td>
    <td width="132">&nbsp;</td>
    </tr>
    <tr>
    <td colspan="3">&nbsp;</td>
    </tr>
    </table>
    </body>
    </html>


    Wo ist denn da was falsch?!

    Danke für Hilfe!
     
  2. timo_paul

    timo_paul Inaktiv

    hmpf...

    versuch mal einfach des per css zu loesen also

    .backgroundimage {
    background-image: url(./gfx/header.jpg);
    }

    und dann noch halt

    <tr class="backgroundimage">
    ...
    ...
    ...
    </tr>

    denn per css hast du einiges an mehr moeglichkeiten.

    gruss
    der timo
     
  3. Litronic

    Litronic Inaktiv

  4. oliverp19

    oliverp19 Inaktiv

    ich machs auch immer mit css, das sollte klappen.
     
  5. Kuscheltier

    Kuscheltier Inaktiv

    Wenn das Bild in der Tabelle nciht angezeigt wird, dann überprüf einfach mal den Link den du gesetzt hast ob der auch so wirklich korrekt ist! Bei normalen grafiken wird das Weiße Kästchen mit rotem Kreuz angezeigt,. bei Hintergrundbildern aber leider nciht :)

    Ansonsten mach es so wei schon beschrieben lieber per CSS, ist besser, einfacher und HTML konformer da background bei Tabelle funktioniert, aber eigentlich nciht vorgesehen wurde!
     
  6. Dahli

    Dahli Inaktiv

    Danke für eure Antworten!
     
  7. akidnaz

    akidnaz Guest

    hab den fehler :) (glaube ich)

    das hast du, den header in einem ordener

    background="gfx/header.jpg


    und es müsste heissen

    background="header.jpg

    bilder in einer tabelle als bg gehen nicht wenn sie sich in einem order befinden sie müssen bei dw im selben ordner wie die html datei sein dann geht es

    frag mich nicht warum versuchs mal


    mfg
     
  8. Dahli

    Dahli Inaktiv

    Die Datei ist aber nicht im selben Ordner wie die index.html!
     
  9. akidnaz

    akidnaz Guest

    gfx/header.jpg

    hast du dein bild so genannt ?

    mit / im bildernamen

    dann wird aber nach dem bild in einem unterordner namens gfx gesucht




    mfg
     
  10. Dahli

    Dahli Inaktiv

    Es hat sonst imemr geklappt, nur jetzt nicht! Das is doch unbegreiflich:(
     
  11. Einsx1

    Einsx1 Inaktiv

    Hi,

    also wenn Du es nicht mit CSS machen willst würde ich Dir diese Variante mal empfehlen. Ich würde den Hintergrund in den TD Tag einbauen, wie ich es unten mal gemacht habe.

    Hier kannst Du dann auch ne genaue Position für dein Logo eingeben.


    <body>
    <table width="100%" height="393" border="0">
    <tr><td height="150" colspan="3" style="background-image:url('hier muss die URL von deinem Bild rein'); background-repeat:no-repeat; background-attachment:fixed; background-position:0px 0px;"></td>
    </tr>
    <tr>
    <td width="143" height="294"> </td>
    <td width="700"> </td>
    <td width="132"> </td>
    </tr>
    <tr>
    <td colspan="3"> </td>
    </tr>
    </table>
    </body>
    </html>

    Gruß
     
  12. akidnaz

    akidnaz Guest


    sag ich doch dw eigenart nur warum weiss ich auch nicht ... ;)

    mfg
     
  13. Dahli

    Dahli Inaktiv

    Hmm, naja, vielleicht klappt`s ja in einem jahr wieder:D
     
  14. azrael

    azrael Inaktiv

  15. Dahli

    Dahli Inaktiv

    Hallo,

    ich hab es endlich geschafft! Ich musste nur den Pfad von "ausgehend von Dokument" auf "Relativ" ändern:)
     
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen